
Tutorial: Building and Deploying a Run-Time Image 
This tutorial takes you through the process of setting up, building, and deploying a Windows XP Embedded run-time 
image. 

This tutorial takes approximately two hours to complete. 

This tutorial assumes you have installed Windows XP Embedded as described in the Installation Guide. Additionally, 
this tutorial requires a second hard drive, onto which the image is deployed. 

In this tutorial, you complete the following major steps to create a run-time image: 

Step 1: Set up the Development System 

Step 2: Create a Component for Target Devices 

Step 3: Create a New Configuration 

Step 4: Update the Configuration Settings 

Step 5: Check Dependencies 

Step 6: Build the Windows XP Embedded Run-Time Image 

Step 7: Deploy the Windows XP Embedded Run-Time Image 

See Also 

Getting Started 

 

Last updated on Friday, October 20, 2006 

© 2006 Microsoft Corporation. All rights reserved. 

 

Step 1: Set up the Development System 
This tutorial requires that you configure your system to support the deployment of a Windows XP Embedded image by 
adding a second hard disk to your system. The first disk is for Windows XP Professional and the Windows XP 
Embedded tools. The second disk is where your Windows XP Embedded OS image will be deployed.  

1. After installing Windows XP Professional and Windows XP Embedded tools, turn off the system.  
2. Add the second hard drive to an empty slot on the IDE bus. This tutorial uses the following settings: 

 IDE Channel 1, Master: Windows XP Professional  
 IDE Channel 1, Slave: Windows XP Embedded OS deployment disk  

3. Turn on the system and log on to Windows XP.  
4. Right-click My Computer and choose Manage. The Computer Management window opens.  
5. Select Disk Management from the Computer Management console tree. The Logical Disk Manager displays the 

available media on your system.  
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6. Right-click the unallocated space of the new hard disk (disk1) and select New Partition. Use the New Partition 
Wizard to create a primary partition, formatted for NTFS.  

7. Access and edit your Boot.ini file, adding a line for the second hard disk. The Boot ARC path changes according 
to the IDE port to which the hard disk is configured. The Boot ARC path to add for this tutorial is multi(0)disk(0)
rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Embedded" /fastdetect. For example, see the 
following Boot.ini file: 

[boot loader] 
timeout=30 
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS 
[operating systems] 
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Embedded" /fastdetect 

You are now ready to create a new component for the devices on your system. 

See Also 

Step 2: Create a Component for Target Devices | Tutorial: Building and Deploying a Run-Time Image 
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Step 2: Create a Component for Target Devices 
After your system is configured to support the deployment of a Windows XP Embedded image, you can create a devices 
component. The device component includes support for all the hardware attached to your system, including device 
drivers for video, networking, and so on.  

1. Navigate to the Program Files\Windows Embedded\Utilities directory.  
2. Run Tap.exe. 

The resulting Devices.pmq file appears in the Program Files\Windows Embedded\Utilities directory.  

3. Run Component Designer.  
4. From the File menu, choose Import. 

The Choose File for Import dialog box appears.  

5. In the file list, choose Devices.pmq file and then choose Open. 

The Import File dialog box appears.  

6. Choose the Start button to import the Devices.pmq file into Component Designer. 

It can take several minutes for the entries in the Devices.pmq file to be matched with the device drivers available 
in the database.  

7. Choose the Close button when the import finishes. 

The Devices.sld file appears in the SLD browser pane. 
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8. From the File menu, choose Save to save the .sld file. 
9. From the Tools menu, choose Component Database Manager. 

The Component Database Manager opens.  

10. Choose the Database tab, and then choose Import. 

The Import SLD dialog box appears.  

11. Browse to the Devices.sld file, choose it, and choose Open.  
12. Choose Import. 

The .sld file is added to the database and the devices component is added to the database.  

13. Close the Import SLD dialog box and the Component Database Manager.  
14. Close Component Designer.  

You are now ready to create a new configuration. 

See Also 

Step 3: Create a New Configuration | Step 1: Set up the Development System | Tutorial: Building and Deploying a Run-
Time Image | Identify Target Device Hardware 
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Step 3: Create a New Configuration 
After creating a devices component, you can start building your run-time image. In Target Designer, you add 
components to your configuration. A configuration is a collection of components that constitutes a Windows XP 
Embedded OS image.  

1. Run Target Designer.  
2. From the File menu, choose New. 

The New Configuration dialog box appears.  

3. Type in a configuration name, for example, MySystem, and choose OK. 

The MySystem.slx configuration appears in the configuration editor.  

4. From the Component Browser, drag the devices component to the configuration editor pane. 

The devices component is added to the configuration.  

5. In the Search box, type Explorer Shell and choose the Search icon. 

The Explorer Shell component, located in the Software\System\User Interface\Shells\ node, is highlighted in the 
component browser.  
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6. Drag the Explorer Shell component to the configuration editor pane. The Explorer shell is added to the 
configuration.  

7. Using the same technique, add the following components: 

Note   Search starts from your last selected node in the component browser, and searches down from there. Select 
the top-level node in the component before choosing the Search icon.  

 NTFS (Software\System\System Services\Base node)  
 NT Loader (Software\System\System Services\Base node)  
 NTFS Format (Software\System\Storage & File Systems\Applications node)  
 Language Support to choose a default language component (Software\System\International\Infrastructure 

node)  
 User Interface Core (Software\System\User Interface\Shells\Windows Shell)  

You are now ready to update the configuration settings. 

See Also 

Step 4: Update the Configuration Settings | Step 2: Create a Component for Target Devices | Tutorial: Building and 
Deploying a Run-Time Image 
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Step 4: Update the Configuration Settings 
After creating your run-time image, there are several configuration settings that you must update, depending on the 
requirements of your run-time image and the target device.  

1. Expand the User Interface Core component in the configuration editor and choose Settings. 

The User Interface settings appear in the details pane.  

2. Select the following check boxes: 
 Show My Computer on Start Menu  
 Show Desktop icons  
 Show Help and Support on Start Menu  
 Show Control Panel on Start Menu  
 Show Network Connections on Start Menu  
 Show Search on Start Menu  
 Show Run on Start Menu  
 Show Log Off on Start Menu (default)  
 Show Shut Down on Start Menu (default)  
 Show Internet Explorer on Start Menu  
 Show All Programs list on Start Menu  
 Lock Task bar (default)  
 Use Windows Classic folders (default)  
 Enable Drag and Drop on Start Menu (default)  

3. At the top of the MySystem node in the configuration browser, choose Settings. 

The configuration settings appear in the details pane. 

Windows XP Embedded SP2 Feature Pack 2007  

Page 4 of 7Tutorial: Building and Deploying a Run-Time Image

3/13/2025file://C:\Documents and Settings\Jonathan_Moore\Local Settings\Temp\~hh4323.htm



4. Under Target Device Settings, choose Show. 
5. Type the correct values for the second hard disk where the Windows XP Embedded OS will be deployed. For 

example, a second hard disk, with the letter D: and boot arc path of rdisk(1)partition(1) would require the 
following values: 

 Boot drive: D:  
 Windows folder: D:\WINDOWS  
 Program Files folder: D:\Program Files  
 Documents and Settings folder D:\Documents and Settings  
 Boot ARC path: multi(0)disk(0)rdisk(1)partition(1) (default)  
 Boot partition size (MB): 5000  
 Partition cluster size (bytes): 4096 (default)  

You are now ready to check the dependencies of your configuration. 

See Also 

Step 5: Check Dependencies | Step 3: Create a New Configuration | Tutorial: Building and Deploying a Run-Time 
Image 
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Step 5: Check Dependencies 
After configuring your run-time image, check its dependencies before building.  

1. From the Configuration menu, choose Check Dependencies. 

The dependency check may run for a few minutes or longer, depending on the performance capabilities of your 
computer.  

2. When the dependency check has completed, choose Close. 

A task is added to the Tasks tab whenever more than one component is available to resolve a dependency.  

3. If there are no tasks, proceed to Step 6: Build the Windows XP Embedded Run-Time Image. 

- or -  

Double-click a task on the Tasks tab.  

The Resolve Dependency dialog box appears, and describes how many components must be selected to resolve 
the dependency, and listing the components available to do so.  

4. Select components to resolve this dependency and choose Add.  
5. Resolve all of the dependencies listed on the Tasks tab. 

Note   Resolving dependencies may introduce new dependencies. 

6. Run the dependency check again, resolving any additional tasks. 
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Do this until no tasks appear on the Tasks tab. 

7. After resolving all dependencies, close the Dependency Check dialog box.  

You now have a complete configuration that is ready to build into a run-time image. 

See Also 

Step 6: Build the Windows XP Embedded Run-Time Image | Step 4: Update the Configuration Settings | Tutorial: 
Building and Deploying a Run-Time Image 
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Step 6: Build the Windows XP Embedded Run-Time 
Image 
After resolving all dependency issues for your configuration, you are ready to build it.  

1. In Target Designer, choose the Configuration menu, and then choose Build Target Image. 

The Build MySystem.slx dialog box appears.  

2. Verify that the build type is set to Release, and then choose Build. 

A message may be displayed about overwriting the contents of the Windows Embedded Images directory. Choose 
Yes to delete the directory contents.  

Build progress is displayed in the Build MySystem.slx dialog box.  

3. After the build completes, choose Close.  
4. On the File menu, choose Save.  
5. Close Target Designer when finished.  

You are now ready to deploy your run-time image. 

See Also 

Step 7: Deploy the Windows XP Embedded Run-Time Image | Step 5: Check Dependencies | Tutorial: Building and 
Deploying a Run-Time Image 
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Step 7: Deploy the Windows XP Embedded Run-Time 
Image 
After the run-time image is built, it can be deployed.  

1. In Windows Explorer, navigate to your run-time build directory, for example, C:\Windows Embedded Images.  
2. Copy the contents of the build directory to your second hard disk. 

For example, select all the files and directories in the build directory and drag them to the D: drive.  

3. Restart your system.  
4. At the Microsoft Windows OS Selection prompt, select your second hard disk. For example, select Microsoft 

Windows XP Embedded. 

The Microsoft Windows XP Embedded splash screen is displayed and FBA starts.  

5. FBA reboots your system. At the Microsoft Windows OS Selection prompt, select to boot the second hard disk to 
complete the First Boot Agent phase. 

After the First Boot Agent phase is complete, you are automatically logged onto your Microsoft Windows XP 
Embedded system as administrator.  

You have successfully deployed a run-time image. Using the steps and examples provided in this tutorial, you can 
create a run-time image for a specific target device.  

See Also 

Step 6: Build the Windows XP Embedded Run-Time Image | Tutorial: Building and Deploying a Run-Time Image 
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